MacOS System Requirements, Conventions, and Installation

System requirements

This toolkit is known to run on MacOS Snow Leopard 10.7.x (latest update). We no longer test on Leopard (10.5.x) and Snow Leopard (10.6.x), but previous versions of MAT have been known to run straightforwardly on these platforms. We believe that Mountain Lion (10.8.x) also works, but we haven't tested it rigorously.

This toolkit depends on a number of external tools which must be installed before you install MAT. For the Mac version, they are:


The conventions are identical to the Unix conventions.


To prepare MacOS for installation of this toolkit, follow these steps:

Once you've completed these steps, you may proceed with the installation, as follows:

During the installation, you might be prompted for various paths and locations which the toolkit requires.

When the installation is complete, your runtime environment will be configured for you. The installed directory is not relocatable; you must rerun the installer if you move the installation.

Upgrading dependencies or moving the installation

If you want MAT to use a new version of Java or Python because the Java or Python on your machine has been upgraded and the old version is no longer present, just rerun the installer. The installer will find the updated versions and reconfigure your tools.

If you want to move the MAT installation from one location to another on the same machine, just move the toplevel MAT directory - it's completely self-contained. If you want to move the MAT installation to another machine, the safest thing to do is reinstall on that new machine.